mirror of
https://github.com/foo-dogsquared/nix-module-wrapper-manager-fds.git
synced 2025-01-30 16:57:59 +00:00
25 lines
347 B
Nix
25 lines
347 B
Nix
let
|
|
sources = import ./npins;
|
|
in
|
|
{
|
|
pkgs ? import sources.nixos-unstable { },
|
|
}:
|
|
|
|
let
|
|
docs = import ./docs { inherit pkgs; };
|
|
website = docs.website { };
|
|
in
|
|
pkgs.mkShell {
|
|
inputsFrom = [ website ];
|
|
|
|
packages = with pkgs; [
|
|
npins
|
|
treefmt
|
|
nixfmt-rfc-style
|
|
|
|
# For easy validation of the test suite.
|
|
yajsv
|
|
jq
|
|
];
|
|
}
|