nix-module-wrapper-manager-fds/shell.nix
2024-11-12 18:08:31 +08:00

25 lines
347 B
Nix

let
sources = import ./npins;
in
{
pkgs ? import sources.nixos-unstable { },
}:
let
docs = import ./docs { inherit pkgs; };
website = docs.website { };
in
pkgs.mkShell {
inputsFrom = [ website ];
packages = with pkgs; [
npins
treefmt
nixfmt-rfc-style
# For easy validation of the test suite.
yajsv
jq
];
}