nix-module-wrapper-manager-fds/tests/configs/lib-modules-subset/make-wraparound.nix
Gabriel Arazas c2625afbff
Some checks failed
Check test suite / Check outputs (push) Has been cancelled
Deploy documentation site / Build website (push) Has been cancelled
Deploy documentation site / Deploy website (push) Has been cancelled
Update Nix dependencies / update-nix-deps (push) Has been cancelled
chore: reformat codebase
2025-01-12 17:58:39 +08:00

36 lines
673 B
Nix

{
config,
lib,
pkgs,
wrapperManagerLib,
...
}:
let
inherit (wrapperManagerLib) makeWraparound;
in
{
build.variant = "shell";
wrappers.tmux = makeWraparound {
under = lib.getExe' pkgs.boxxy "boxxy";
underFlags = [
"--rule"
"~/.tmux.conf:~/.config/tmux/tmux.conf"
];
underSeparator = "--";
arg0 = lib.getExe' pkgs.tmux "tmux";
};
build.extraPassthru.wrapperManagerTests = {
actuallyBuilt =
let
wrapper = config.build.toplevel;
tmux = lib.getExe' wrapper "tmux";
in
pkgs.runCommand "wrapper-manager-tmux-actually-built" { } ''
[ -x "${tmux}" ] && touch $out
'';
};
}