mirror of
https://github.com/foo-dogsquared/nix-module-wrapper-manager-fds.git
synced 2025-01-30 22:57:58 +00:00
33 lines
595 B
Nix
33 lines
595 B
Nix
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
yourMomName,
|
|
...
|
|
}:
|
|
|
|
{
|
|
wrappers.neofetch = {
|
|
arg0 = lib.getExe' pkgs.neofetch "neofetch";
|
|
executableName = yourMomName;
|
|
appendArgs = [
|
|
"--ascii_distro"
|
|
"guix"
|
|
"--title_fqdn"
|
|
"off"
|
|
"--os_arch"
|
|
"off"
|
|
];
|
|
};
|
|
|
|
build.extraPassthru.wrapperManagerTests = {
|
|
actuallyBuilt =
|
|
let
|
|
wrapper = config.build.toplevel;
|
|
in
|
|
pkgs.runCommand "wrapper-manager-neofetch-actually-built" { } ''
|
|
[ -x "${wrapper}/bin/${config.wrappers.neofetch.executableName}" ] && touch $out
|
|
'';
|
|
};
|
|
}
|