mirror of
https://github.com/foo-dogsquared/nix-module-wrapper-manager-fds.git
synced 2025-01-30 22:57:58 +00:00
36 lines
830 B
Nix
36 lines
830 B
Nix
let
|
|
sources = import ../npins;
|
|
in
|
|
{
|
|
pkgs ? import sources.nixos-unstable { },
|
|
}:
|
|
|
|
let
|
|
wrapperManagerLibTests = import ./lib { inherit pkgs; };
|
|
inherit (pkgs) lib;
|
|
in
|
|
{
|
|
configs =
|
|
let
|
|
configs' = import ./configs { inherit pkgs; };
|
|
updateTestName =
|
|
configName: package:
|
|
lib.mapAttrs' (n: v: lib.nameValuePair "${configName}-${n}" v) package.wrapperManagerTests;
|
|
in
|
|
lib.concatMapAttrs updateTestName configs';
|
|
|
|
lib =
|
|
pkgs.runCommand "wrapper-manager-fds-lib-test"
|
|
{
|
|
testData = builtins.toJSON wrapperManagerLibTests;
|
|
passAsFile = [ "testData" ];
|
|
nativeBuildInputs = with pkgs; [
|
|
yajsv
|
|
jq
|
|
];
|
|
}
|
|
''
|
|
yajsv -s "${./lib/tests.schema.json}" "$testDataPath" && touch $out || jq . "$testDataPath"
|
|
'';
|
|
}
|