mirror of
https://github.com/foo-dogsquared/nixos-config.git
synced 2025-01-30 22:57:55 +00:00
22 lines
437 B
Nix
22 lines
437 B
Nix
{ dockerTools, foodogsquaredLib, rustc, cargo, rust-bindgen, rust-analyzer
|
|
, nodejs }:
|
|
|
|
dockerTools.buildImage {
|
|
name = "fds-rust-backend";
|
|
|
|
copyToRoot = foodogsquaredLib.buildFDSEnv {
|
|
name = "fds-rust-backend-root";
|
|
paths = [ cargo rust-bindgen rust-analyzer rustc nodejs ];
|
|
};
|
|
|
|
runAsRoot = ''
|
|
mkdir -p /data
|
|
'';
|
|
|
|
config = {
|
|
Cmd = [ "/bin/bash" ];
|
|
WorkingDir = "/data";
|
|
Volumes."/data" = { };
|
|
};
|
|
}
|