mirror of
https://github.com/foo-dogsquared/nixos-config.git
synced 2025-01-30 22:57:55 +00:00
41 lines
625 B
Nix
41 lines
625 B
Nix
# The GNU build system. Commonly used for projects at GNU and anyone who wants
|
|
# to be a GNU fanatic.
|
|
#
|
|
# It's a good thing they have documented the full details in one of their
|
|
# manuals at
|
|
# https://www.gnu.org/software/automake/manual/html_node/GNU-Build-System.html
|
|
{ mkShell
|
|
, lib
|
|
, autoconf
|
|
, autoconf-archive
|
|
, automake
|
|
, gnumake
|
|
, gcc
|
|
, gettext
|
|
, coreutils
|
|
, pkg-config
|
|
, help2man
|
|
, texinfo
|
|
}:
|
|
|
|
mkShell {
|
|
packages = [
|
|
autoconf
|
|
autoconf-archive
|
|
automake
|
|
coreutils
|
|
gettext
|
|
gcc
|
|
gnumake
|
|
help2man
|
|
texinfo
|
|
pkg-config
|
|
];
|
|
|
|
inputsFrom = [
|
|
gcc
|
|
coreutils
|
|
gnumake
|
|
];
|
|
}
|