mirror of
https://github.com/foo-dogsquared/nixos-config.git
synced 2025-01-30 22:57:55 +00:00
21 lines
633 B
Nix
21 lines
633 B
Nix
{
|
|
description = "Basic Rust app development flake";
|
|
|
|
inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
|
|
|
|
outputs = { nixpkgs, ... }:
|
|
let
|
|
inherit (nixpkgs) lib;
|
|
systems = [ "x86_64-linux" ];
|
|
forAllSystems = f: lib.genAttrs systems (system: f system);
|
|
in {
|
|
devShells = forAllSystems (system:
|
|
let pkgs = import nixpkgs { inherit system; };
|
|
in { default = import ./nix/shell.nix { inherit pkgs; }; });
|
|
|
|
packages = forAllSystems (system:
|
|
let pkgs = import nixpkgs { inherit system; };
|
|
in { default = pkgs.callPackage ./nix/package.nix { }; });
|
|
};
|
|
}
|