mirror of
https://github.com/foo-dogsquared/nixos-config.git
synced 2025-01-30 22:57:55 +00:00
25 lines
650 B
Nix
25 lines
650 B
Nix
{
|
|
description = "Very simple sample of a Nix flake with NixOS and home-manager";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
|
|
home-manager.url = "github:nix-community/home-manager";
|
|
};
|
|
|
|
outputs = { nixpkgs, home-manager, ... }:
|
|
let
|
|
system = "x85_64-linux";
|
|
in
|
|
{
|
|
nixosConfigurations.desktop = nixpkgs.lib.nixosSystem {
|
|
inherit system;
|
|
modules = [ ./hosts/desktop ];
|
|
};
|
|
|
|
homeConfigurations.foodogsquared = home-manager.lib.homeManagerConfiguration {
|
|
pkgs = import nixpkgs { inherit system; };
|
|
modules = [ ./users/foodogsquared ];
|
|
};
|
|
};
|
|
}
|