mirror of
https://github.com/foo-dogsquared/wiki.git
synced 2025-01-30 16:58:00 +00:00
3e09432e6f
Which is exactly what's its made for. :)
34 lines
508 B
Nix
34 lines
508 B
Nix
{ pkgs ? import <nixpkgs> { } }:
|
|
|
|
let
|
|
python3WithPackages = pkgs.python3.withPackages(p:
|
|
with pkgs.python3Packages; [
|
|
pynvim
|
|
jupyter
|
|
black
|
|
]);
|
|
in
|
|
pkgs.mkShell {
|
|
buildInputs = with pkgs; [
|
|
flow
|
|
gcc
|
|
gnumake
|
|
gnuplot
|
|
graphviz
|
|
jq
|
|
lilypond
|
|
libcs50
|
|
nodejs-16_x
|
|
octaveFull
|
|
python3WithPackages
|
|
racket
|
|
R
|
|
recoll
|
|
|
|
# A bunch of formatters...
|
|
stylua # ...for Lua.
|
|
rustfmt # ...for Rust.
|
|
nixpkgs-fmt # ...for Nix.
|
|
];
|
|
}
|